NeGiMeMo.net

ねぎさんのメモ帳。日常・メモ・ときどきWordPress。

jQuery 1.8がでてたのね

bell賞味期限切れコンテンツ

この記事は公開または最終更新から1512日くらい経過しています。
このメッセージが表示されている記事(特にプログラミング系)は情報が古くなっている可能性があるので注意して下さい。

jsFiddleを久しぶりに開いたら,フレームワークの選択肢にjQuery 1.8.0が追加されてて気付いたんですが,
いつの間にかでてたんですねー。

まぁあんまりもともとjQuery詳しくもないんで更新内容みてもよくわかんなかったけど…。
なんかパワーアップしたらしい。

ScriptSrc.netではまだ1.7.2みたいですが。様子見なのかな?
いつも仕事とかで構築するときはここからコード拾ってるんで,まぁ安定してるほうを使えるって意味では
当面はこれでいいのかな。

勿論,Google Hosted Librariesにはちゃんと1.8.0もありますので,どうしても使いたいならここから拾えば良いわけだし。
でもいちいち行くのも面倒なのでここにメモっておこう

WPのfunctions.phpとかでwp_enqueue_scriptのjqueryをこれに差し替えるならば,

とかそんな感じでいいらしい。です。
さっき試してみたら,wp_enqueue_scriptをつかうときは http省略記法はだめっぽかったので,必ず
http: または https: からかかないとダメみたいです。

jqueryって文字はもう既に1.7を読み込むように本体が予約してるので,一度 wp_deregister_script をつかって,それを解除して,改めて wp_enqueue_script で jquery に登録すればOKなんだそうだ。

この方法を使えば,最新版だけじゃなくて,好きなバージョンのを読み込めますね。

 

因みにjsFiddleひらいた理由は,こう,仕事中にちょっとあとで使えるかなって思ってとっておいたスクリプトを入れておいたんですが,どうも保存に失敗したようで,結局また週明けに会社でやりなおしになりそうです。
まぁそんな複雑なことじゃないし,日曜日とかにたらたらと思い出しながらやっても良いんですがね。 

TAGS