NeGiMeMo.net

ねぎさんのメモ帳。日常・メモ・ときどきWordPress。

最近の WordPress で内蔵 jQuery 以外の jQuery を使う

bell賞味期限切れコンテンツ

この記事は公開または最終更新から913日くらい経過しています。
このメッセージが表示されている記事(特にプログラミング系)は情報が古くなっている可能性があるので注意して下さい。

以前にwp_enqueue_scriptに関する記事を書いたことが有りましたが、いつの間にかこの方法だとエラーが出るようになっていたので対策を調べてみました。

これまでの手法はダメになったっぽい?

前回記事にした時は、functions.php でこのように書いていました。

しかし、この方法だと WP_DEBUG が TRUE の時、ログイン画面や管理画面で次のようなエラーがでるようになりました。

Notice: wp_deregister_script が誤って呼び出されました。管理画面では jquery スクリプトの読み込みをオフにしないでください。フロントエンドテーマだけをターゲットにするには、wp_enqueue_scripts フックを使いましょう。 詳細は WordPress のデバッグをご覧ください。 (このメッセージはバージョン 3.6 で追加されました) in (ファイル名) on line (行番号)

(オフの時は確認してませんが、動作しないとなるともしかしたら表示されなくなってるのかも…?)

原因を考える

どうも、これまでのように、init にフックした上で if (!is_admin()){} として管理画面では動かないようにする、という手法だけではダメになったようです。

読み込みの順番とかがなんか内部の処理とかが変化したのでしょうか?

で、どうすればいいか

エラーの中にしっかりと「wp_enqueue_scripts フックを使いましょう」と書いてありますね。

なので、フック先を init から wp_enqueue_scripts に変更します。

これでエラーは消えました。

よかったよかった、です。

TAGS