NeGiMeMo.net

ねぎさんのメモ帳。日常・メモ・ときどきWordPress。

SassとかCompassとかをアップデートする

bell賞味期限切れコンテンツ

この記事は公開または最終更新から992日くらい経過しています。
このメッセージが表示されている記事(特にプログラミング系)は情報が古くなっている可能性があるので注意して下さい。

先日フロントエンドのセミナーに参加した際に、Sassの新しいバージョンにいろんな便利機能が追加されたと聞いて、とりあえず手元のSassとかCompassをアップデートしてみることにしました。

また新しいのが出た時はこれやることになると思うので忘れないようにメモっておきます。

まずはバージョンを確認

バージョンを確認するには黒い画面で「sass -v」です。

この間のアップデートでたしか3.3.1がでてるらしいので、ちょっと古いですね。
今日公式サイトみたら更にアップデートがかかってて3.3.2でした。(書き留めていたら公開までに3.3.3が出ちゃいました)

続いてCompass。これも「compass -v」で分かります。

とりあえず、うちの環境はちょっと古いということが改めてわかったので、最新版にしていきましょう。

Gemのアップデート

まず、RubyGemをアップデートします。

バージョンを確認

Sassのアップデート

続いてSassをアップデートします。

こちらもバージョンを確認

これで完了です。

Compassのアップデート

あらためてバージョン確認

これにて無事アップデートが出来たようです。

TAGS